express不是内部或外部命令,也不是可运行的程序或批处理文件

安装express: --> npm install -g express

查看版本: --> express -V (一定要是大写的V)

结果报出: --> express不是内部或外部命令,也不是可运行的程序或批处理文件


网上找了一下原因,是因为express在4.0以后把命令工具单独分出来了,所以安装完express后,还得再安装express-generator;

如果不是采用的全局安装,则需要把 "安装路径\node_modules\.bin"放到环境变量中才能运行


安装express-generator: --> npm install -g express-generator

查看express的版本: --> express -V

C:\>express -V

4.2.0


修改时间 2016-07-14

真诚赞赏,手留余香
赞赏
随机推荐
npm国内镜象设置的三种方法
PHP判断file框是否已选择文件
使用 Photoshop 创建矢量图标库 Iconfont
PHP开发api接口安全验证
阿里的后端安全规约
通过JS语句判断WEB网站的访问端是电脑还是手机
HTTP Authorization 之 Basic Auth
Photoshop CC 2018中如何设置19号笔刷
ThinkCMF URL美化
macOS卸载Android Studio